Yeti Owners Club banner

1 - 3 of 3 Posts

·
Registered
Joined
·
760 Posts
Discussion Starter #1
Here are a few photographs of our month long holiday in Australia. We are from Perth, Western Australia and travelled to Mansfield in country Victoria, which is near the snow skiing resort of Mout Buller. After crossing the Nullarbor we drove around the coast of the Eyre Peninsula to visit Smoky Bay, Streaky Bay, Venus Bay, Port Lincoln, Tumby, Arno Bay and Whyalla. A few days later we stayed for a night in the old Gladstone Gaol S.A. Then it was off to the Clare and Barossa Valleys for a taste or two of grape juice. We then headed for Swan Reach on to the River Murray to enjoy both the river and the history of the many old port towns, such as Blanchtown, Morgan, Loxton, Mildura, Robinvale, Echuca to name most. And finally to Mansfield for a surprise visit with our friends and two weeks of fun and laughter, before heading home to good old W.A.

After 8121km, two washes, a polish and a darn good vacumn the Yeti is gleaming once again. We averaged 7.4litre per 100km or 38miles per gallon, which I was rather pleased with, especially after driving for 8 hours through a cold front with winds gusting up to 85km an hour and lots of rain on the nullarbor on our way home. Those head winds sure increased the fuel consumption.
 

·
Registered
Joined
·
94 Posts
Hello Banjobach,
I had a similar problem with uploading photos. When I posted images of my new Yeti, I had five photos in the submission but only three appeared in the final post.

I wonder what we are doing wrong and maybe other members have encountered this and found the solution.

Incidentally, I live near Mansfield, Pommieland. Just that bit dfferent from Mansfield, Aussieland!
 
1 - 3 of 3 Posts
Top