Yeti Owners Club banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Just thought i would make a quick post to tell how i fixed my leaking boot.
I got my 2016 Yeti in February, within a few days i was taking a look around the boot and i noticed that the carpet was a little damp in one place, upon lifting up the carpet i noticed that the " battery box " had around 2 inches of water in it ! The car came with a month warranty with the dealer so i took it in to my main dealer to sort out. They were sure it was the boot vents in the rear valence so replaced them, said that it had been checked after with water and it was all sorted now.
Some months later i went back in to the bottom of the boot and surprise it was full of water again !
Doing a search on the internet showed that quite a few owners had the same problem but there were no real answers as to the cause of the problem then i happened upon a post where a gent who had the problem said his dealer had replaced a damaged / ill fitting boot strut bracket and that seemed to have fixed the issue so i thought i would check mine. Upon checking the bolts holding the strut brackets all the bolts in both brackets were barely finger tight !
The design of these brackets are very poor indeed and i am sure more people have leaks and dont realise, the bracket lies in what is a drainage channel, it is held in place by countersink bolts that have no threadlock on. In my experience countersink bolts tend to bind before they can be done up super tight and if fitted without threadlock in an application that experiences levering forces or vibration are prone to coming undone.
Also the gasket fitted to my mind is totally unsuitable, it appears to be a paper gasket that is bonded to the bracket but is unlikely to make a good seal on a painted surface.
My solution was to take everything off, clean it up and refit the brackets with some clear silicone and threadlock on the bolts. This was done a couple of months ago and the boot has been bone dry ever since. Hope this post is of help to someone :)
 

·
Administrator
Joined
·
4,884 Posts
Welcome to the forum and thank you for a comprehensive first post :)
 
  • Like
Reactions: Tay100

·
Registered
Joined
·
1,032 Posts
Welcome to the forum and thank you for a comprehensive first post :)
Could this go into Yetipedia, for those of us who may come across the problem in the future?
 

·
Registered
Joined
·
153 Posts
This prompts me to post a reminder caution about the strut mountings. About eighteen months ago one of the struts on my Yeti was making a clicking noise when the rear door was opened. Turned out that the mounting screws at the body end were very loose. This allowed the mounting plate to move, hence throwing the strut out of line. Problem easily fixed. About a month ago I conducted, my now usual, half yearly check on the screws and yes both sides were loose again. I have subsequently followed Tay100's advice and added some Loctite. Loose screws is clearly a common problem so my advice to all is to check those mounting screws.

Still on the topic of the rear struts, as we have quite a number of shingle roads here dust gets all over the struts. As the rear door is opened the dust wipes itself onto the strut piston arm as it extends, which can then feed back into the top strut piston seal when the door is closed, which then gets smeared onto the arm when the door is opened again, etc, etc. The only solution I have found is to wipe the strut arms when extended but this removes any lubricant. I'm loathe to use anything too 'sticky' to re-lubricate the arm and am a bit concerned about using CRC 40 type lubricants for fear of them running down the arm into the internal part of the piston - or is this not a problem? Comments / suggestions welcome.
 

·
Premium Member
Joined
·
5,077 Posts
I was always told that the struts shouldn't be lubricated.
 

·
Premium Member
Joined
·
5,441 Posts
I was always told that the struts shouldn't be lubricated.
Me too! For the exact reasons Upsidedown quotes. Just give the pistons a wipe down to keep them clean. The lubricant residue attracts dust. Which then forms a good grinding paste on the seals and pistons every time the strut is extended. Perhaps just a drop of lub inside the ball joint ends though?
 
  • Like
Reactions: Llanigraham

·
Registered
Joined
·
153 Posts
Thanks gentlemen. (am I allowed to say that last word these days?!) In line with my thoughts.
 
1 - 9 of 9 Posts
Top