Yeti Owners Club banner

1 - 20 of 27 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Vehicle is a Skoda Yeti Outdoor Auto SE L 4x4 tdi scr 2.0 148 bhp. Black Reg: Apr 2017

Have found the answer to the problem of the Maxidot Display showing Kph instead of Mph for a UK registered Skoda vehicle.

The Skoda Manual indicates that MPH can be selected by entering the SETTINGS menu and scroll down to the "Alt.display dis." sub-menu to make the change... but.... this particular 'sub-menu' has been removed for ALL Skoda UK vehicles....

From extensive enquiries made (not with Skoda, they just refuse any involvement), I have established that the sub-menu (item 10) can be re-instated by simply changing the Country CODE from United Kingdom to ROW (Rest of the World) i.e. Australia. This can only be carried out by a technician at a garage that has a VCDS Unit available.

The MPH is then displayed in LARGE letters. The cost of this change is around £54.00 and takes approx 15 min. and its done.

A simple matter to change back again IF you travel to Europe.

The 'procedure' is similiar to changing your watch from GMT to BST and has absolutely no affect to the functions of the vehicle. Its a display!

Available to discus in more detail as required...
 

·
Registered
Joined
·
737 Posts
us old'uns here have known about the 'Australian" VCDS change for a long time.there is plenty about it via the Search facility.

maybe £54 by a dealer but you may find a YOC member near you who will do it for beer money.
 

·
Registered
Joined
·
114 Posts
Interesting, while scanning with my monthly VCDS check for any fault codes I thought I would try this. Tryingto change to anything except UK shows a window saying "Numbers out of range" and refuses to change. Is it me?
Mel
 

·
Administrator
Joined
·
14,595 Posts
This is what I do with mine, if you try it, it is at your own risk.

To change the country go to 17- Instruments and click on "Coding - 07"
Then click on "Long Coding Helper"
Finally under Bit 4 select "70 Country: Australia (AUS)"...or 20 US
Exit this screen and return to the previous screen (with the current & new coding displayed) see that the long coding has changed, click on "Do it!" all will then be saved.
Once you have made the changes with VCDS you then need to go into the maxi-dot menu:

SETTINGS,Units,
"Consu/distance" change this back to mpg (GB), mi (as it defaults to 1/100km, km),

then

SETTINGS,MFD data make sure the box for Digit.speed is ticked
 

·
Registered
Joined
·
114 Posts
Yup, done that. Tried AUS, USA and ROW but still displays in Km although the coding changes to the appropriate country. Units are set to MPG in the MFD and tried unticking and re ticking the digi display but it stubbonly refuses to change.
Definately must be me.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
Maxidot Display....SETTINGS Menu scroll down to sub-menu 10.
should read "Alt.Speed dis."

does it...?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
It would be most helpful if those members that say "i can do it for the price of a beer etc"for them to post EXACTLY.... step-by-step what should be done.
Using the VCDS unit and their fingers.....
if these members have nothing to loose, i.e. a fee, then they have much to gain from members who are stuck and want help and nothing to loose.........
 

·
Premium Member
Joined
·
5,866 Posts
ajmbwas said:
It would be most helpful if those members that say "i can do it for the price of a beer etc"for them to post EXACTLY.... step-by-step what should be done.
Using the VCDS unit and their fingers.....
if these members have nothing to loose, i.e. a fee, then they have much to gain from members who are stuck and want help and nothing to loose.........

They have their reputation to lose, there are plenty that cannot follow instructions or make a mistake and then may say that the instructions have screwed up the ECU.

There are plenty of help pages on the Ross-Tech that explain most changes, also on YouTube etc.


Edited by: Urrell
 

·
Administrator
Joined
·
14,595 Posts
ajmbwas said:
It would be most helpful if those members that say "i can do it for the price of a beer etc"for them to post EXACTLY.... step-by-step what should be done.
Using the VCDS unit and their fingers.....
if these members have nothing to loose, i.e. a fee, then they have much to gain from members who are stuck and want help and nothing to loose.........
Did you not read my post a couple up from yours?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #11
OK, lets try and clarify........... with absolutely NO responsibility whatsoever.

a. You will need a VCDS Unit to re-program the Maxidot. If you have one available and IF you understand how to use same then....

b. As I understand it... you then attempt to change the Country to other than europe.
c. Once you have achieved this then,
d. As I understand it.... this process re-instates the Item 10 of the SETTINGS Menu
which is "Alt.Speed dis."

IF and only IF this sub-menu re-appears then you can then make the change from Kph to MPH.

By far, the safest way to do ALL and achieve what you require is to pay a professional to do it for you. OK so its around £54.00... but its well worth it,,, rather than play around. IF you pay someone then they have a responsibility to get it right.

Good luck.
 

·
Premium Member
Joined
·
5,866 Posts
ajmbwas said:
OK, lets try and clarify........... with absolutely NO responsibility whatsoever.

a. You will need a VCDS Unit to re-program the Maxidot. If you have one available and IF you understand how to use same then....
What was wrong with the Hood's instructions that he pointed out to you in case you missed them a few posts ago in this thread?

The Hood said:
This is what I do with mine, if you try it, it is at your own risk.

To change the country go to 17- Instruments and click on "Coding - 07"
Then click on "Long Coding Helper"
Finally under Bit 4 select "70 Country: Australia (AUS)"...or 20 US
Exit
this screen and return to the previous screen (with the current &
new coding displayed) see that the long coding has changed, click on "Do
it!" all will then be saved.
Once you have made the changes with VCDS you then need to go into the maxi-dot menu:

SETTINGS,Units,
"Consu/distance" change this back to mpg (GB), mi (as it defaults to 1/100km, km),

then

SETTINGS,MFD data make sure the box for Digit.speed is ticked
 

·
Registered
Joined
·
114 Posts
ajmbwas said:
Maxidot Display....SETTINGS Menu scroll down to sub-menu 10.
should read "Alt.Speed dis."

does it...?
Yes it does but still nothing has changed, apart from the country.
When I first bought VCDS it hadn't been updated to work on the 150 engine, despite people telling me it had, although all other functions worked . Since then further updates have enabled all functions but this is the first time I've had any difficulty changing the coding. All appears to be correct but it still doesn't work. Very strange.
 

·
Registered
Joined
·
114 Posts
Well, despite the Hoods best efforts to help it still doesn't work! I now give up.

 

·
Administrator
Joined
·
14,595 Posts
Have you tried with both keys?

Changing the KPH to MPH is not key specific but for some reason one of my keys stopped working and KPH came back. I changed backwards and forwards between Aus and UK several times without resolving it. Then I tried UK to US and both keys worked, then out of curiosity I changed US to Aus and both keys still worked!
 

·
Registered
Joined
·
114 Posts
Neither key is working at the moment but I'll give it a go and update you later. Not bothered whether it's there or not but it's becoming a challenge. I really would like to solve this.
 

·
Premium Member
Joined
·
5,866 Posts
Clutching at straws.
There is another page on the Maxidot where you can choose what details are displayed, could it be that it needs a tick in the box there?
 

·
Registered
Joined
·
114 Posts
Well, I've now spent several hours trying every possible combination of keys and country. Tried leaving it 30 minutes before turning the ignition back on, tried ticking and unticking boxes with as many combinations of other commands I can think of but it still steadfastly refuses to work. The country changes without problem, the units all change without problem but the Kph refuses to change.
Now I really have to admit it's beaten me!
 

·
Registered
Joined
·
3 Posts
Hello everyone! Just purchased a 2017 2.0 Diesel 4x4 DSG Yeti, very impressed so far! Soon stumbled across the unit conversion problem, and here we are 😂 don’t suppose anybody knows of any Skoda dealerships in the north west that can deal with this problem? My local is Warrington but they don’t have the correct machine to fix.
many thanks! And greetings to all!
 
1 - 20 of 27 Posts
Top