Yeti Owners Club banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi, greetings from Essex - home of the spiv! I've had my white 2.0 litre diesel 'Elegance' since February and I'm absolutely delighted! The reg is AV60OAP which is about right for a bloke of my age. I haven't heard the 4WD click in yet and I haven't pressed the off road button yet. Roll on winter!
Regards,

Mike
 

·
Registered
Joined
·
77 Posts
Welcome Mike. One of the, I think, missed opportunities of the Yeti is that you have no knowledge of when the 4wd kicks in. It just does it magically and you keep driving unaware of the technology.

I was only mildly aware a few times last year in the snow and that was when I was going around a corner and felt the car slide and then suddenly correct itself. I assume the 4wd had kicked in then but there are no flashing lights or sirens going.

My wife was once picking me up in the Yeti, during the snow as it was the only safe car we had, and as she came towards me I saw one of the front wheels had stopped turning whilst the car was still moving. I asked her what the car had felt like and she had no idea of what I was talking about. Very clever stuff.
 

·
Premium Member
Joined
·
5,077 Posts
Edmund is correct, the activation of the 4x4 system is so smooth you hardly notice it happening.
 

·
Registered
Joined
·
83 Posts
OAP... I remember that!

I was behing you some time back driving up the A12 from London towards Chelsmford.
Wasn't in the Yeti though, I was in the Fabia.

It was white and clean, looked nice.
 
1 - 4 of 4 Posts
Top