Yeti Owners Club banner

1 - 9 of 9 Posts

·
Registered
66 L&K
Joined
·
1 Posts
Discussion Starter #1
Hi there, having had Yetis since 2013 and recently purchased my latest, a 66 reg L&K, I decided it was time to join the “club” I have a couple of queries that someone might be able to help with.
Firstly, on reading some of the posts, I find quite a few remarks on problems with leaks from the panoramic sun roof on the L&K which is a bit worrying. Hopefully there are some L&K owners out there who can reassure me that it’s not a general fault and they have not experienced any issues with their sun roof.
Secondly, on my previous Yetis, whenever I operated switches or knobs to alter things, eg temperature, air-con, fan speed etc, the written confirmation popped up on the screen for a couple of seconds. On my L&K this doesn’t happen. Is this due to the Amundsen unit fitted, my previous had the Columbus fitted, or is it my particular L&K?
Any advice will be gratefully accepted.
 

·
Premium Member
Joined
·
5,866 Posts
Air-Con settings etc. no longer come up on screen, probably since Amundsen II November 2014 on..
The pano roof does seem to be a weak point but I suspect the majority have no problems with it.
Welcome to the Forum (y)
 

·
Administrator
Joined
·
5,031 Posts
Welcome Keithybabe :)

Forums by their nature are where people come and share their problems but there has been enough people commenting on the sunroof issues with the yeti to think there is a bit more than bad luck involved. If you are not having the same issue then long may it continue and it's good to have some balance.
 

·
Registered
Joined
·
12 Posts
Hi there, having had Yetis since 2013 and recently purchased my latest, a 66 reg L&K, I decided it was time to join the “club” I have a couple of queries that someone might be able to help with.
Firstly, on reading some of the posts, I find quite a few remarks on problems with leaks from the panoramic sun roof on the L&K which is a bit worrying. Hopefully there are some L&K owners out there who can reassure me that it’s not a general fault and they have not experienced any issues with their sun roof.
Secondly, on my previous Yetis, whenever I operated switches or knobs to alter things, eg temperature, air-con, fan speed etc, the written confirmation popped up on the screen for a couple of seconds. On my L&K this doesn’t happen. Is this due to the Amundsen unit fitted, my previous had the Columbus fitted, or is it my particular L&K?
Any advice will be gratefully accepted.
Bought my 2014 Yeti 12 months ago. Sunroof leaked like a sieve. My wife said it was a mobile aquarium. Dealer fixed under warranty which involved removal of the cassette, replace gasket and drain tubes. Since then it's watertight.
 

·
Registered
Joined
·
46 Posts
Welcome to the forum Keithybabe. I have a Dec 2016 1.4 TSI L+K and so far, despite some VERY heavy prolonged soakings, it has remained bone dry inside. When I got it 3 years ago I tried the sunroof out of interest, very nice but I have not used it since, and have no plans to, it just came with the car. As has been said, if people have problems they will share them of course. And some have had a real bad time with leaking sunroofs. So far maybe I've been 'lucky'. As for the rest of the car, I love it.
 

·
Registered
Joined
·
737 Posts
Air-Con settings etc. no longer come up on screen, probably since Amundsen II November 2014 on..
The pano roof does seem to be a weak point but I suspect the majority have no problems with it.
Welcome to the Forum (y)
As Urrrell says..........no longer..........lives outdoors and no problems..........and welcome!
 

·
Registered
Joined
·
441 Posts
If it's any consolation, my L&K sunroof does't leak either! :)

I am practising safe leaks though, giving the tubes an occasional swill out and the application of Gummi Pfledge on the rubbers (doesn't need any innuendo from you - Jimmy))
 
1 - 9 of 9 Posts
Top