Yeti Owners Club banner
1 - 20 of 26 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter · #1 ·
Hi all.

My Bolero has been working fine up until this week. Came back to the car and started driving it home and noticed the clock was not showing. Turned unit on and just got start up screen and radio playing I was unable to adjust volume or anything. After about 30 seconds it would reboot (go blank then logo screen appeared) still only showing logo and plays radio .
Got home removed fuse 8 and still the same.
Disconnected battery still the same.
Reversing sensors still work but no display.
Now and then I can control the volume (stuck on same station).
No Bluetooth connection.
No radio display in the matrix.

New radio or any other suggestion.

Thanks
Richard.


Yeti 2017 2.0 diesel outdoor.
 

·
Registered
Joined
·
527 Posts
A frequent suggestion for this type of problem is 'How old is your battery?' Modern vehicle electrical systems can behave in bizarre and unpredictable ways if the battery is low in charge or in need of replacing. There should be a year stamped on one of the battery terminal posts if in doubt.
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #3 · (Edited)
A frequent suggestion for this type of problem is 'How old is your battery?' Modern vehicle electrical systems can behave in bizarre and unpredictable ways if the battery is low in charge or in need of replacing. There should be a year stamped on one of the battery terminal posts if in doubt.
Will check standing voltage and year of manufacture.
Back of my mind was thinking it could be battery related.
 

·
Administrator
Joined
·
15,990 Posts
My battery was still starting the car first time when the resting voltage was 11.2, the first notification was when a womans voice told me to turn off the radio to protect the battery and then the radio shut itself down. If your battery was on the way out one of the first things that may start acting differently on a 2017 Yeti is the stop/start.
 

·
Registered
Joined
·
820 Posts
If your battery was on the way out one of the first things that may start acting differently on a 2017 Yeti is the stop/start.
On mine, the stop/start system ceased to function six months before the (faulty) Moll battery eventually gave up.
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #6 ·
After it sitting for about 24 hours battery is showing 12.39. Will look for the manufacture date tomorrow.
 

·
Administrator
Joined
·
5,707 Posts
Slightly worryingly we do seem to have seen more infotainment problems being reported lately than in previous years.
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #8 ·
Did a scan with Carista and get 2 reoccurring codes.
CAN network gateway:
01305 - Databus for Infotainment
Instrument cluster:
13654544
Still no working radio.
 

·
Premium Member
2015 Elegance Greenline II
Joined
·
6,776 Posts
How about drawing it out and making sure all connections at the rear are secure.

 

·
Registered
Joined
·
65 Posts
Discussion Starter · #10 ·
How about drawing it out and making sure all connections at the rear are secure.

I have taken it out and all connections at the rear all seen OK. Not sure where to trace them back to.
 

·
Registered
Joined
·
1 Posts
I have a similar problem. Radio started flicking from my chosen station to Classic FM. Now radio is stuck on AM Punjab Radio! Won't respond to touch screen or buttons, nor steering wheel buttons.
Have removed radio, unplugged and reconnected several times. No difference.
If I have my phone on me, the infotainment system connects to the phone but controls don't all work.
What to do?
 

·
Registered
Joined
·
1,366 Posts
Welcome johnontheroad to this very excellent forum, and hopefully someone with answers will be along soon.
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #13 ·
Still no luck with the radio. So it's going in for some investigation. Been looking in to aftermarket radios, seems a bit of a mind field different fittings and plugs just want a simple plug and play.
 

·
Registered
Joined
·
2 Posts
Still no luck with the radio. So it's going in for some investigation. Been looking in to aftermarket radios, seems a bit of a mind field different fittings and plugs just want a simple plug and play.
My 2015 Yeti 4X4's info dystem will do 0since new battery. Tried to recode but all I get is Welcome to Skoda. Nsfgled and can ferl prob unnecessary, ecoensive replacement coming if go to dealers..
 

·
Premium Member
2015 Elegance Greenline II
Joined
·
6,776 Posts

·
Registered
Joined
·
2 Posts
Do you mean the radio was asking for a code, it should be stored in the ECU if the same radio.
It isnt asking for anything. Nothing works and all I get is Welcome to Skoda. Local garage tried rebooting it. No joy . They said to take to dealers but this site say they are in denial aboit how crso rhe system us and sell yoi whole new, equally flawed kaboodle.. HELP!
 

·
Premium Member
Joined
·
5,746 Posts
Sorry, but none of this is making any sense.
Can you please explain in simple words what you have done and what is happening?
 

·
Registered
2015 Yeti Outdoor SE 1.2TSi DSG, Jungle Green
Joined
·
4 Posts
My radio has been playing up recently too. It started changing channels from the left preset to the preset three quarters across the screen and I have to really press hard on anything on the left-hand side of the touchscreen. In phone mode, it starts randomly dialling the favourite in that three-quarter position and in all menus it starts pressing that position. It wasn't great yesterday morning in the sound menu - it decided to put the volume up to full! It has also scrolled across three preset screens and saved a new favourite by itself. Hard resets don't seem to improve matters.

Did have low battery messages at the end of lockdown due to lack of use but has been OK after a couple of long journeys.

Now hardly using the radio with this issue and also looking at aftermarket replacement unless I can sort this.
 

·
Premium Member
Joined
·
5,746 Posts
My radio has been playing up recently too. It started changing channels from the left preset to the preset three quarters across the screen and I have to really press hard on anything on the left-hand side of the touchscreen. In phone mode, it starts randomly dialling the favourite in that three-quarter position and in all menus it starts pressing that position. It wasn't great yesterday morning in the sound menu - it decided to put the volume up to full! It has also scrolled across three preset screens and saved a new favourite by itself. Hard resets don't seem to improve matters.

Did have low battery messages at the end of lockdown due to lack of use but has been OK after a couple of long journeys.

Now hardly using the radio with this issue and also looking at aftermarket replacement unless I can sort this.
If you had battery problems earlier I am very doubtful that a few long journeys will have solved the problem. You need to do a resting voltage test to see what voltage the battery is now holding.
 

·
Registered
2015 Yeti Outdoor SE 1.2TSi DSG, Jungle Green
Joined
·
4 Posts
Thanks, Llanigraham, I've just tested my battery at rest and it is reading 12.1v so does look like a replacement is definitely required.

Will be interesting to see if this resolves the radio issues but very much doubt how low voltage/spikes could cause the touchscreen to become possessed!
 
1 - 20 of 26 Posts
Top