Yeti Owners Club banner

1 - 8 of 8 Posts

·
Registered
Joined
·
102 Posts
Discussion Starter #1
Had my Urban a week now and loving it. Has anyone noticed that the rear wiper has an area at the top of the arc that does not clear the window. I turned off the ignition at the 12 0'clock position and noticed that the last 2" of blade does not quite connect with the glass - hence the missing area.
 

·
Administrator
Joined
·
14,185 Posts
Just checked mine, and it clears the glass for the full arc, however the top of the arc passes over the black coloured border but it still retains contact.
 

·
Registered
Joined
·
102 Posts
Discussion Starter #5
It is not really an issue for me but will pop in to local dealer (8 miles away in Milton Keynes) for them to have a look. Usually I can sort "minor" issues myself as I hate letting dealers loose on a new car (or an old one). I used to work at a main dealership and it is usually the "new young lad" who gets these simple jobs and ends up making a right hash of it.
 

·
Administrator
Joined
·
14,185 Posts
Just had another look at mine, when the arm is at 12 o'clock and lowered onto the glass, the bottom contacts first. The wiper is easy to remove, have you tried turning it 180 degrees so the opposite end contacts first? The thin metal stiffener might have an uneven curve.
 

·
Registered
Joined
·
102 Posts
Discussion Starter #7
Good idea - will let you know. Yeti all put to bed under his cover now, so will have to wait until tomorrow. I love these forums for answers - where would we be without the net?
 

·
Registered
Joined
·
35 Posts
TRUTHSEEKER said:
I love these forums for answers - where would we be without the net


What 'net'?...........is this another question?




Sorry, couldn't resist.
 
1 - 8 of 8 Posts
Top