Yeti Owners Club banner

1 - 17 of 17 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi all,

I picked up my new Yeti from the dealer yesterday. So far, I have managed a massive 10 miles around my part of London, though I am heading off to Norfolk tonight.

Positives are the fit and feel of the cabin - it just feels like a quality build. I went for a sunroof and already are delighted with that and the extra speakers I specced. It also handles the speedbumps around London better than my previous cars and the general handling is brilliant. Very precise.

I also went for the MDI, being told, I thought, by the salesman that it could handle an iphone 5. It can't, and it also came without a cable for an iphone 4. The dealer tells me these get stolen at the ports all the time and he has ordered a replacement.

Most annoying was a small chip at the front of the car next to the grille. It means that the car has to go in a couple of weeks for a respray.

Overall though, I am delighted with the car and looking forward to a longer run in it this weekend.
 

·
Registered
Joined
·
266 Posts
I thought the MDI cables were extras but if you're getting one supplied that's fine as they can be expensive. I gotIpod and USB cablesas part of the deal with my last Octavia. A fantastic car but didn't cope that well with Yorkshire winters. Picked up the Yeti in time forlast winter and it didn't put a wheel wrong.
As other people have said you'll keep on enjoying the Yeti experience.

Keith
 

·
Registered
Joined
·
94 Posts
Hi PaxtonPete. It`s great that you finally have your Yeti but it sucks that a chip was allowed to get through the pre-handover inspection. Or do I take it that the dealer discovered it when they did it?
When I took possession of mine, I was so excited that I didn`t go over the bodywork with a fine tooth comb so it was only later that I discovered the remains, in odd nooks and cranies, of the adhesive backing from the white protective plasic they use when transporting it. The valeters at the dealers had not removed it thoroughly enough!

A revalet - free obviously - sorted it all out.

Good luck! Get some photos taken and posted! That`s an order!!!
 

·
Premium Member
Joined
·
1,141 Posts
What's the issue with the MDI & Iphone 5?
I've ordered the MDI (saw that you can buy cables on fleabay for about £10) and I have an iPhone 5S. I know there isn't a lightning (8-pin) iPhone adaptor yet, but my 30-pin to 8-pin adaptor has allowed me to use the iPhone 5S on everything that's iPhone 4/4S compatible.

Also, having ordered the 12 speaker system also, I'm intrigued to learn how it compares to the standard 8-speaker setup - which I have to admit was bloody good in the one we test-drove. I would not have paid for the extra speakers but managed to bargain it in for free.

Did you listen to an 8-speaker setup to compare against?

Sorry for the q's but I have a 3+ mth wait for mine and I'm keen to speak to anyone who has any of the extras that I ordered!!!
 

·
Premium Member
Joined
·
1,627 Posts
As above, what issues are you having with phone?All functionswork in my yeti using Apple lightning adaptor and iphone 5.Oh and I wasnt supplied with mdi cable either, bought genuine one from ebay for around £10.




Edited by: Kenny R
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
Re the MDi, there is no Skoda cable to lightning. Yes, I can use an adaptor but I have had a couple of these and they don't seem to last. It would be nice to have a cable with a lighting lead. As the iphone 5 has been out for over a year now, you might have thought VAG would have produced one. In the meantime, I can use a 12v charger and bluetooth the music.

As for the speakers, sound in the car is one of the most important things to me. I listened to only the standard set up of 8 speakers in the dealers prior to buying. It was ok, but not good enough for me. I am very pleased that I coughed up for the extra speakers. It now sounds better than my old Merc, which was good.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
I'm now up to about 350 miles on the new Yeti. Very comfortable and fun to drive.

There are, however, couple more issues:

The rear wiper refused to work on my trip to Norfolk. My cousin got it to work once while sitting on his driveway, but then, nothing.

I drove to Heathrow on Sunday and tried it then. Nothing. Coming back from Heathrow last night, it worked fine.

Secondly, 4 times now the Bolero radio has turned itself off and back on again. The only constant seems to be it happens at slow speeds, I have been in traffic each time it happened.

As the car is going into the dealers on Monday for a respray of the chip, I will get these looked at then. As they are intermittent problems, I think they may be difficult to fix.

Anyone on here had similar experiences?
 

·
Registered
Joined
·
266 Posts
The rear wiper should operate for about 6 sweeps when the rear washer is operated and about every 10 to 20seconds if left in the on position. Having said that there have been reports of the rear wiper motor failing. Best to get it checked by the dealer though along with the radio.
Keith
 

·
Administrator
Joined
·
4,438 Posts
Not noticed on the Yeti but my previous VW Touran's rear wiper wouldn't work if the boot wasn't shut properly. Could it be that it's the same onyour Yeti?
 

·
Registered
Joined
·
31 Posts
PaxtonPete said:
Re the MDi, there is no Skoda cable to lightning. Yes, I can use an adaptor but I have had a couple of these and they don't seem to last. It would be nice to have a cable with a lighting lead. As the iphone 5 has been out for over a year now, you might have thought VAG would have produced one.
Also very disappointed about this. Skoda NL can't source a lightning cable (I tracked down the part number but they said it's a VW only part (WTF?). They gave me a USB MDI cable to then plug the standard apple lightning to USB cable in but it doesn't work. Will charge, but won't let you control via MDI. Bit p***ed off about it really, having forked out the 200+ euros for MDI.

Anyone found a workable solution? Does the VW cable work? As per PaxtonPete, I don't fancy using a 30-pin MDI connector and 30pin->lightning adaptor if I can help it.
 

·
Registered
Joined
·
34 Posts
Hi all,
I take delivery of my Yeti 2 litre 150ps L&K on September 1. I have an Ipod Classic 160gb and I notice the connection is via a USB socket.

Can anyone tell me what functions I will get on the Amundsen Touchscreen once the iPod is connected by USD lead?
Is there a MDI retro fit kit for the Amundsen?

Thanks.


Edited by: Highlander
 

·
Premium Member
Joined
·
5,219 Posts
No easy retrofit for Amundsen.

To see for yourself what functions are available with the USB lead download the Amundsen manual Here.
 

·
Premium Member
Joined
·
1,141 Posts
Highlander said:
Hi all,
I take delivery of my Yeti 2 litre 150ps L&K on September 1. I have an Ipod Classic 160gb and I notice the connection is via a USB socket.

Can anyone tell me what functions I will get on the Amundsen Touchscreen once the iPod is connected by USD lead?
Is there a MDI retro fit kit for the Amundsen?

Thanks.
You willhave an Amundsen II in your Yeti, not an Amundsen.
You just connect via USB, not MDI.
 

·
Premium Member
Joined
·
5,219 Posts
Highlander said:
Thank you. I did not know of the Amundsen II. I will see if I can get some spec for it.
I posted the link to download the current manual in my post above!
You could then peruse that and be up to date with all the options when you get it.
 
1 - 17 of 17 Posts
Top