Yeti Owners Club banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Had the Yeti Adventure for two weeks and am very pleased so far. First trip from pickup at the dealer I had to use the sat nav. Used to a tom-tom satnav but the built in one proved OK - straight to my destination - no problem. Miss my Octavia Elegance, but having said that my son now has it so I still see it occasionally. - I traded his Octavia Elegance in for the Yeti. He's already had a drive in the Yeti and likes it - perhaps has his eye on it for the future - but he will have a long wait!Comment from my two year old grandson when he had his first ride in it: "Quite small - but quite smart!"
 

·
Registered
Joined
·
222 Posts
Hi CoulyO,
Welcome to the forum.
I also picked up my Adventure 3 weeks ago and he now has1800 miles on the clock and averaging 52mpg on a brim to brim basis. The magidot appears to overead by about 7%.
Only problem that I've experenced so far is that I'm still trying to get as comfortable a seat setting as I had on my previous Yeti.
Hope you will be as pleased with yours as I am with 'Seedy'
Shanco.
 

·
Registered
Joined
·
94 Posts
Hi There CoulyO!


I think that we might cross paths some day as I`m near Mansfield and you are somewhere in Notts.


I bought mine from Rainworth Motors, finding them much better than the first Skoda dealers we dealt with at Farmers in Nottingham.


We are both newbies and I hope that you are enjoying driving the Yeti as much as I am!


Bwanamdevu
 

·
Registered
Joined
·
368 Posts
Hi Bwanamdevo (think I got the right?),

I got my Yeti (used) from Rainworth too and thought they were very good.

Came all the way up from near Oxford.

They have a great coffee machine also - couldn't get enough of the stuff.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Still very pleased with the yeti. Had a bit of a shock yesterday when I got home, switched off the ignition and noticed the radiator fan was still running. And it was pouring with rain. Got the manual out and read that the fan could run up to 10 minutes after switching off. Just shouldn't happen on a cold wet dark night when I couldn't see a thing!!! Won't be too concerned if it happens again.
 

·
Premium Member
Joined
·
2,460 Posts
couly0 said:
Still very pleased with the yeti. Had a bit of a shock yesterday when I got home, switched off the ignition and noticed the radiator fan was still running. And it was pouring with rain. Got the manual out and read that the fan could run up to 10 minutes after switching off. Just shouldn't happen on a cold wet dark night when I couldn't see a thing!!! Won't be too concerned if it happens again.

The fans running on on a cold wet day will probably be due to it doing g a regen of the DPF filter, would also have a burning smell, when it gets up to temp next time just hold a low gear for a while and get the exhaust good and hot to make sure its clean.

The wife poodles around so when I drive it I hold a gear lower for a mile or 2, revving it around 2000-2500 must help as it has only had the fans run on about 3 or 4 times in nearly 3 years.
 
1 - 6 of 6 Posts
Top